the fast, reliable localhost tunneling solution


PageKite 0.5.8b, libpagekite updates and service status

By Bjarni RĂșnar 2016-02-23, 16:58

Version 0.5.8b of pagekite.py has been released and is available for download.

This is a minor release, if PageKite 0.5.7 or newer is working fine for you, then you do not need to upgrade.

Highlights since version 0.5.7a:

The last fix is the most notable - if you are seeing SSL3_WRITE_PENDING errors in your logs, you probably want to upgrade to this release.

Progress on libpagekite

In other news, a lot of progress has been made in the past few months on libpagekite, which is the high-performance re-implementation of PageKite in C.

The API is now relatively stable, it is well documented and bindings are included for Java and Python.

Libpagekite is already used in multiple products that take advantage of the PageKite.net white-label offering. If you are developing a product which could benefit from embedding PageKite functionality, feel free to get in touch!

Service Status Updates

If you rely on PageKite for your work, you may want to know about our service status blog. We post to this blog whenever there is an outage which impacts our users. The blog is hosted by Wordpress.com, so it does not share any infrastructure with PageKite itself.

As a rule, we try to be honest and open about why problems occur and what steps are being taken to improve things.

Comments

None, comments are closed.

The Blog

Welcome to the PageKite blog!

Here we write about anything and everything to do with running the service, building a company, open-source, privacy online... you name it.

But mostly it's about PageKite.

Other venues