the fast, reliable localhost tunneling solution

Webmin Debian

2011-12-20, 12:49

Hi there.

I guess I'm just a lazy guy - the answer is probably somewhere around. I just don't know where and I do not have enough knowledge to solve it myself.

So I thought I'll give it a shot and just ask it here on the forum.

How can I access webmin on a Debian server with pagekite?

Webmin, a config GUI tool for administering Debian servers via a web interface, is normally accessed via port 10000.

Can I do that somehow with pagekite (if possible without loosing access to apache)?

I'd be glad for some help.

Thanks in advance


  1. Bjarni RĂșnar Einarsson said on 2011-12-20, 12:58
    There are a few ways to do this. The best is probably to create a sub-kite for the webmin. So if your kite name is ``, you want to create ``. Creating a new name instead of running the webmin on an alternate port allows you to take advantage of the PageKite service's wild-card SSL certificate, which is important to keep your webmin credentials secure.

    You can do this from the command-line, like so:

    $ pagekite --add 10000

    That will take care of registering the kite and adding it to your personal `~/.pagekite.rc` file. Alternately, you can create a new kite by logging on to your account on this website, adding a new kite and then editing the config file by hand.

    If you are using the debian package and want this to be enabled on boot, then you register the new name first using one of the above methods, and then edit /etc/pagekite.d/80_httpd.rc and add an extra backend line, like so:


    The end result should be that your webmin will become visible as
  2. ichi-no-eda said on 2011-12-20, 13:02
    Wow! That was fast! Thanks!

    I'm going to try it right now!
  3. Bjarni RĂșnar Einarsson said on 2011-12-20, 13:23
    Good luck! :-)

    Note that you have a choice in what kind of "sub-name" you create, you can either use a dash - or a . as the delimiter. The dash may feel a bit weird, but it's actually the better choice because of limitations in how browsers handle wildcard SSL certificates. You'll only be able to use un-encrypted HTTP if you choose the version with the dot.
  4. ichi-no-eda said on 2011-12-20, 13:48
    Unfortunately it doesn't work.

    I can add the suggested sub-kite with " --add 10000" but it won't connect after that. (I also have added the sub-kite in my account!)

    I get something like that:

    daniel@owncloud:~$ 10000
    >>> Hello! This is v0.4.5a. [CTRL+C = Quit]
    !!! Failed to connect to
    Connecting to front-end ...
    - Protocols: http http2 http3 https websocket irc finger httpfinger raw
    - Ports: xxx ... ##(no port 10000!)
    - Raw ports: xx virtual
    You have 2554.29 MB of quota left.
    Only connected to 1/2 front-ends, will retry...

    But it cannot connect!

    By the way I have installed pagekite with:
    $ curl -s | sudo bash

    I also do not have the file /etc/pagekite.d/80_httpd.rc. Don't know if this is important.

    Any suggestions?

    The main kite works fine though.
  5. ichi-no-eda said on 2011-12-20, 13:50
    Sorry! It works now! A only had to log out and in!

    Thank you very much!


Leave a comment

( (Please leave these blank: )

We use Gravatar for commenter's photos. Get your own, it's free!