the fast, reliable localhost tunneling solution

I've tried everything and WORDPRESS still will not load

2016-01-23, 22:22

The entire reason I need your service is because of an error I received while trying to import a slider template into a WordPress Page. It is an exported slider template in a .zip file from a site migrated from one localhost environment on a PC to my new localhost environment on my new imac. The error suggested that my zlib archive extension hasn't been loaded.

The staff member for the premium theme I purchased suggested I try a service such as yours so that they could have a look on the backend without having to migrate the site again to a live host.

This is the first I haver ever heard of your service and similar services . I never thought it was possible bring localhost online,. Now that I know, I can see many advantages to using it, if I get it working correctly. The fact I could show my clients work in progress on a localhost staging ground was a very happy moment but short lived. (Smiling)

The problem I am having is that no matter what I do, I can never get the tunnel to load the index.php and the wp-blog header to load the website. This is not regular image linking issues some people have had. In my case, I can't even get the page to load at all.

There are no errors. Instead I recieve, "It Works!" I believe that's the Apache welcoming text but this is all I ever get

Below is my working environment

Imac with the latest OS version I'm using MAMP PRO: The DEFAULT APACHE PORT FOR HTTP CONNECTION: is not port 80 PHP v7.0 Apache 2

The core wp files reside in a folder acting as my site root. With MAMP PRO I do not need to keep my dev sites in hdocs. The root folder is the site name, (i,e) "websitename". However, the default "Document Root" path has not been changed, it is set as the default path leading to MAMP/htdocs.

Question 1: Could on of the issue be that I haven't changed the "Document Root" path to the folder where my site resides or does it not matter?

I am not sure whether I needed to setup a virtual host configuration if I'm already using MAMP. It seems as though it already acts as a virtual host. It even places the " "websitename" localhost" into my host file. Regardless, I configured a virtual host just in case.

I have tried everything suggested from all over the net to resolve the WordPress problem.

As mentioned above I configured a virtual host through MAMP's vhost configuration. I have not touched the mac's local Apache server or it's associated files I would need to edit. I mention this only because all of the files and the Apache server are available within the program's environment, so there is no need to use the Apache server included with Mac. If doing it this way is compounding my problem, please let me know.

The troubleshooting steps I've taken:

I edited httpd .vhost.conf file and the configuration looks like the example below: ( path names are replaced with my personal info)

<VirtualHost *:80>
<a href="/wiki/ServerAdmin/">ServerAdmin</a>
<a href="/wiki/DocumentRoot/">DocumentRoot</a> "Users/my-user-name/Documents/PROJECT-FOLDER/numberd-PROJECT/websitename"
<a href="/wiki/ServerName/">ServerName</a>
<a href="/wiki/ServerAlias/">ServerAlias</a> locahost
<a href="/wiki/ErrorLog/">ErrorLog</a> "logs/"
<a href="/wiki/CustomLog/">CustomLog</a> "logs/" common

It should be noted that I've also tried replacing port 80 with the one being used in MAMP

In the httpd.conf file I uncommented: Include /Applications/MAMP/conf/apache/extra/httpd-vhosts.conf

*In WordPress I have tried several different things:

I added the suggested github relative link plugin because of Wordpress's absolute linking structure. This didn't resolve the issue. Infact whenever the plugin is activated, the frontend WP index page fails to load even in the localhost environment. However, the backend WP Admin pages do load successfully.

*I added a plugin called "add-any host name." then within the plugin, I added, ""

*I've tried manually editing the WP HOME URL and SITE URL directly in the sql database within PhPMYAdmin.

*I tried adding these suggested define strings to the WP_config file:

define('WP_HOME',     'http://' . $_SERVER['HTTP_HOST']);
define('WP_SITEURL',  'http://' . $_SERVER['HTTP_HOST']);

This tells wordpress to ignore them so the index page can be called up (without breaking.) by the whatever the url is set to inside the host server

From the command line:

I've shut down the firewall which had no effect. I used a flag to tell the server to index all of the files. This gave me some success which allowed me to view of the files in the root folder, and that is the only successful kite I've seen.

Being able to give access to the indexed root folder is something the support team will most likely need in case he needs to check any source code for errors. The only problem I've had is I haven't been able to apply the +password attribute.

Question two: Is that something that needs to be added inside the kite config file rather than from the command line?

It doesn't implement the password protection from the command line with the format string I've tried using. It flies the kite but with unprotected open access to the indexed root which I don't want. I need it to be protected. I've tried using several command string at once to implement what I need.

Here is an example of one of the string formats I used: /Users/my-user-name/Documents/PROJECT-FOLDER/numberd-PROJECT/ +indexes=all +apassword/user=example

*I also tried applying the password while the kite is flying but I get the kite already is taken error.

*I've tried flying the kite using port 80 and also the port set inside MAMP.

From The Browser:

*I typed in several different variations of the http:// protocol. and then some followed by the port: (both :80 and the one used by MAMP

There is most likely a lot of other troubleshooting examples I'm leaving out but I wanted to make sure you saw the most prominent ones I have tried.

What am I leaving out? There is something I'm not implementing right, can you help me figure it. It's either a forgotten step o a syntax error. Anything you can do to help me would be greatly appreciated.



None yet, you can be first!

Leave a comment

( (Please leave these blank: )

We use Gravatar for commenter's photos. Get your own, it's free!